(Do not try to copy and paste the commands that I have written for your reference since some
commands may not be suppored by your IOS. So, try to issue each and every commands manually.)
Step 1:
At first, we configure both the routing protocols as shown in the diagram. Make sure that you have
configured specific prefix on R2 when advertising network into both protocols.
Example:
router eigrp 100
no auto-summary
network 10.1.12.2 0.0.0.0
(0.0.0.0 indicates that you have particularly 10.1.12.2 matched and no
other IP can participate in eigrp)
Once you are done with the routing protocol configuration, configure each loopback as OSPF point-topoint
network. Since OSPF treats the loopback network as a host route and advertises it as /32 network
regardless of the actual prefix length of the network. So, to intact the prefix original, you have to define
the interface as point-to-point.
Example:
On R3
interface range loopback0
ip ospf network point-to-point
Step 2:
As you are asked to configured two way redistribution for full network reachability, you can have very
minimal configuration as part of the solution.
When redistributing OSPF into EIGRP, you should define metric parameters which are compatible with
EIGRP metric calculation because anything you redistribute into EIGRP will have infinite metric.
If you redistribute any routing protocol into OSPF, all the routes will have the default metric of 20. So,
here in this case we are going to redistribute EIGRP into OSPF which doesn’t require seed metric but if
we want all the classess and classful network into OSPF, we should add “subnets” keyword along with
the redistribution command.
On R2
router ospf 1
redistribute eigrp 100 subnets
router eigrp 100
redistribute ospf 1 metric 1500 100 1 255 1500
Step 3:
In this particular task, you are asked to allow only the odd numbered routes to be installed into OSPF
network. R2 is the border router and it doesn’t make sense if we filter any prefix to be installed into the
routing table of R2. So here in this case, you will create an access-list on R3 and apply it under the OSPF
subcommand mode with distribute-list, which only restricts any prefix to be installed into RIB, not in the
OSPF database.
On R3:
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.1.3.0 0.0.0.255
access-list 1 permit 10.1.5.0 0.0.0.255
router ospf 1
distribute-list 1 in
Step 4:
Finally, you are asked to allow only the routes having prefix length greater than /25 to be installed into
EIGRP domain. So, the only option we have is prefix-list, which can match the wild card bits and it has
the capability of checking prefix-length too. We create a prefix-list and bind it into route-map which has
two sequence number 10 and 20. Sequence number 10 is used to match and deny the network
mentinoed in the prefix-list BLOCK.
On R2:
ip prefix-list BLOCK 10.0.0.0/8 ge 25
route-map FILTER deny 10
match ip address prefix-list BLOCK
route-map FILTER permit 20
router eigrp 100
redistribute ospf 1 metric 1500 100 1 255 1500 route-map FILTER
Verification commands for the lab:
On R2:
show ip protocols
show run | sec router
sh route-map
sh ip prefix-list
sh access-list
On R1:
sh ip route eigrp
sh ip protocols
On R3:
show ip route ospf
sh ip ospf database
sh run | sec router ospf
sh access-list
Good luck ☺
0 comments:
Post a Comment